Ubuntu 配置 vim 开发环境

2018年8月28日15:02:44 发表评论 96

升级 vim 版本

安装 vim-plug 插件管理器

安装 vim-go 插件

vim ~/.vimrc

保存 .vimrc 退出后,再次启动 vim 用命令 :PlugInstall 安装vim-go

或者使用命令 vim +PlugInstall +qall 安装

等到显示 Finishing ... Done!  说明 vim-go 插件已经安装好了。

另外卸载不需要的插件,只需要把对应的插件用 " 符号注释掉,然后在 vim 的命令模式下执行 :PlugClean

安装 YouCompleteMe 插件

除了 YouCompleteMe 还一并安装了 vim-airline、molokai、vim-airline-theme、tagbar 等插件

下面是我用到的 .vimrc 配置:

安装编译工具:

sudo apt-get install build-essential cmake

确保安装了 python-dev:

sudo apt-get install python-dev python3-dev

进入到 ~/.vim/plugged/YouCompleteMe下,执行下面命令:

./install.py --clang-completer --go-completer

avatar

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: